Hola, soy nuevo en la cuestión de los iPhones y tengo muchas dudas. Me acaban de vender un iPhone 4 CDMA americano (Verizon versión 10.2) activado en Iusacell con número telefónico y con PRL 330 y ERI 0 (aún no pruebo la funcionalidad de datos o si es que funciona). El chiste es que tiene iOS 4.2.8 (8E401) y quiero actualizarlo por lo menos al 5.1.1 pero he intentado todos los iOS para CDMA que he encontrado y siempre me aparece el error "el iphone xxxx no ha podido actualizarse. Este dispositivo no es compatible con la versión solicitada". La forma en que intento actualizarlo es darle "alt" + click en actualizar para seleccionar la versión (siempre selecciono los iOS para CDMA) ya que he leido que si se restaura se puede perder toda la configuración de la linea. Por lo que veo no tiene jailbreak pero la verdad desconozco completamente con qué metodo lo configuraron.

Ojalá y me puedan ayudar, gracias de antemano.